Configuring EIGRP
To
start an EIGRP session on a router, use the router eigrp command followed by
the autonomous system number of your network.
Then
use the network command followed by the network numbers connected to the
router.
Example
of enabling EIGRP for autonomous system 20 on a router connected to two
networks, with the network numbers being 10.3.1.0/24 and 172.16.10.0/24:
Router#config
t
Router(config)#router
eigrp 20
Router(config-router)#network
172.16.0.0
Router(config-router)#network
10.0.0.0
Remember—as
with RIP, you use the classful network address, which is all subnet and host bits
turned off.
Understand
that the AS number is the same in all
routers , You can use any number from 1 to 65,535.
If
you need to stop EIGRP from working on a specific interface, such as a BRI
interface or a serial connection to the Internet. you would flag the interface as passive using
the passive-interface interface command:
Router(config)#router
eigrp 20
Router(config-router)#passive-interface
serial 0/1
Doing
this will prohibit the interface from sending or receiving Hello packets and,
This means that it won’t send or receive route information on this interface.
Ex.
Corp#config
t
Corp(config)#router
eigrp ?
<1-65535>
Autonomous system number
Corp(config)#router
eigrp 10
Corp(config-router)#network
10.0.0.0
As
with RIPv1,you still need to add the classful network numbers you want to
advertise. But unlike RIP,
EIGRP
uses classless routing—but you still configure it as classful. Classless, which
I’m sure
you
remember, means that the subnet mask information is sent along with routing
protocol
updates
(RIPv2 is classless).
Configuring Discontiguous Networks
Remember
first Figure and how it demonstrated how EIGRP would auto-summarize the
boundaries on a discontiguous network? Take a look at that figure again, Both
routers, by default, would automatically summarize the classful boundaries and routing
would not work. Here’s the configuration that would make this network work:
Lab_A#config t
Lab_A(config)#router eigrp 100
Lab_A(config-router)#network 172.16.0.0
Lab_A(config-router)#network 10.0.0.0
Lab_A(config-router)#no auto-summary
Lab_B#config t
Lab_B(config)#router eigrp 100
Lab_B(config-router)#network 172.16.0.0
Lab_B(config-router)#network 10.0.0.0
Lab_B(config-router)#no auto-summary
Because
I used the no auto-summary command, EIGRP will advertise all the subnets between
the two routers.
Load Balancing with EIGRP
By
default, EIGRP can load-balance up to four equal-cost links. And we can
configure EIGRP to load-balance across up to six equal-/unequal cost.
First,
let’s take a look at the R1 routing table and make sure that EIGRP has already
found both links between the routers:
R1#sh ip route
10.0.0.0/24 is subnetted, 12 subnets
D
10.1.11.0 [90/2684416] via 10.1.3.1, 00:50:37, Serial0/0/1
[90/2684416]
via 10.1.2.1, 00:50:37, Serial0/0/0
D 10.1.9.0 [90/2707456] via 10.1.3.1, 01:24:09,
Serial0/0/1
[90/2707456]
via 10.1.2.1, 01:24:09, Serial0/0/0
D 10.1.8.0 [90/2707456] via 10.1.3.1, 01:24:09,
Serial0/0/1
[90/2707456]
via 10.1.2.1, 01:24:09, Serial0/0/0
D 10.1.12.0 [90/2684416] via 10.1.3.1,
00:10:10, Serial0/0/1
[90/2684416] via 10.1.2.1, 00:10:10, Serial0/0/0
C 10.1.3.0 is directly connected, Serial0/0/1
C
10.1.2.0 is directly connected, Serial0/0/0
You
can see that we have two links to every route in our internetwork, and again,
EIGRP will load balance across the s0/0/0 and s0/0/1 links by default because
they’re the same metric.
EIGRP
is automatic load balancing. But how about bundling links? Well, EIGRP can
allow us to do this too—even with no extra configuration! Let me show you how
this works. I’m going to configure the links between our Corp and R1 routers
with the same subnet, meaning both links will have all interfaces within the
same subnet. Check out my configuration:
Corp#config t
Corp(config)#int s0/0/1
Corp(config-if)#ip address 10.1.2.4 255.255.255.0
R1#config t
R1(config)#int s0/0/1
R1(config-if)#ip address 10.1.2.3 255.255.255.0
R1(config-if)#do show run | begin interface
interface Serial0/0/0
description 1st Connection to Corp Router
ip address 10.1.2.2 255.255.255.0
!
interface
Serial0/0/1
description
2nd connection to Corp Router
ip
address 10.1.2.3 255.255.255.0
Now
both links have all four interfaces in the same subnet.
R1(config-if)#do show ip route
10.0.0.0/24 is subnetted, 12 subnets
D 10.1.11.0
[90/2684416] via 10.1.2.4, 00:04:44, Serial0/0/1
[90/2684416]
via 10.1.2.1, 00:04:44, Serial0/0/0
D 10.1.10.0
[90/2707456] via 10.1.2.4, 00:04:44, Serial0/0/1
[90/2707456]
via 10.1.2.1, 00:04:44, Serial0/0/0
D 10.1.9.0
[90/2707456] via 10.1.2.4, 00:04:44, Serial0/0/1
[90/2707456]
via 10.1.2.1, 00:04:44, Serial0/0/0
D 10.1.8.0
[90/2707456] via 10.1.2.4, 00:04:44, Serial0/0/1
[90/2707456]
via 10.1.2.1, 00:04:44, Serial0/0/0
D 10.1.12.0
[90/2684416] via 10.1.2.4, 00:04:44, Serial0/0/1
[90/2684416]
via 10.1.2.1, 00:04:44, Serial0/0/0
C 10.1.2.0 is
directly connected, Serial0/0/0
is
directly connected, Serial0/0/1
D 10.1.1.0
[90/2172416] via 10.1.2.4, 00:03:56, Serial0/0/1
[90/2172416] via 10.1.2.1, 00:03:56,
Serial0/0/0
C 10.1.7.0 is
directly connected, FastEthernet0/1
There
are two changes in the routing table now? Networks 10.1.2.0 and
10.1.3.0 used to show up as individual, directly connected interfaces, but not
anymore. Now only the 10.1.2.0 network shows up as two directly connected
interfaces, and the router now has a 3MB pipe through that line instead of just
two 1.5Mbps T1 links.
Verifying EIGRP
There are several commands can be
used to help you troubleshoot and verify
the EIGRP configuration:
Next TABLE
EIGRP
Troubleshooting Commands
Command
|
Description/Function
|
show ip route
|
Shows the entire routing table
|
show ip route eigrp
|
Shows only EIGRP entries in the routing table
|
show ip eigrp neighbors
|
Shows all EIGRP neighbors
|
show ip eigrp topology
|
Shows entries in the EIGRP topology table
|
debug eigrp packet
|
Shows Hello packets sent/received between adjacent routers
|
Debug ip eigrp notification
|
Shows EIGRP changes and updates
|
The
following router output is from the Corp router in our example:
Show ip eigrp neighbors command:
Corp#sh ip eigrp neighbors
IP-EIGRP neighbors for process 10
H Address Interface Hold Uptime SRTT RTO Q
Seq
(sec)
(ms) Cnt
Num
1 10.1.3.2 Se0/0/1 14 00:35:10 1 200 0 81
2 10.1.4.2 Se0/1/0 13 03:17:20 1 200 0 20
0 10.1.2.2 Se0/0/0 10 03:19:37 1 200 0 80
We read the information in this output
like this:
-
The
H field: the order in which the neighbor
was discovered.
-
The
hold time: how long this router will wait
for a Hello packet to arrive from a specific neighbor.
-
The
uptime: how long the neighborship has been
established.
-
The
SRTT field: the smooth round-trip timer—an
indication of the time it takes for a round-trip from this router to its
neighbor and back.
The
time between multicast attempts is specified by…
-
The
Retransmission Time Out (RTO) field: the
amount of time EIGRP waits before retransmitting a packet to a neighbor.
-
The
Q value: indicates whether there are any
outstanding messages in the queue.
-
The
Seq field: indicates the sequence number
of the last update from that neighbor.
The
show ip eigrp neighbors command allows you to check the IP addresses ,the
retransmit interval and queue counts for the neighbors that have established an
adjacency.
show ip eigrp topology command :
Corp#sh ip eigrp topology
IP-EIGRP Topology Table for AS(10)/ID(10.1.5.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R -
Reply,
r - reply Status, s - sia Status
P 10.1.11.0/24,
1 successors, FD is 2172416 via 10.1.5.2 (2172416/28160), Serial0/2/0
P 10.1.12.0/24,
1 successors, FD is 2172416 via 10.1.5.2 (2172416/28160), Serial0/2/0
P 10.1.3.0/24,
1 successors, FD is 76839936 via Connected, Serial0/0/1
via
10.1.2.2 (9849856/7719936), Serial0/0/0
P 10.1.2.0/24,
1 successors, FD is 2169856 via Connected, Serial0/0/0
via
10.1.2.2 (2681856/551936), Serial0/0/0
P 10.1.1.0/24,
1 successors, FD is 28160 via Connected, FastEthernet0/1
Notice
that every route is preceded by a P. This means that the route is
in the passive state, which is a good thing because routes
in the active state (A) indicate that the router has lost
its path to this network and is searching for a replacement.
Each
entry indicates the feasible distance (FD), to each remote network plus the
next-hop neighbor.
Plus,
each entry also has two numbers in parentheses. The first indicates the
feasible distance, and the second the advertised distance to a remote network.
Now
here’s where things get interesting—notice that under the 10.1.7.0 and 10.1.6.0
outputs there are two links to each network and that the feasible distance and
advertised distance are different. What this means is that we have one
successor to the networks and one feasible successor (a backup route)remember
that even though both routes to network 10.1.6.0 and 10.1.7.0 are in the
topology table, only the successor route (the one
with
the lowest metrics) will be copied and placed into the routing table.
EIGRP
will load-balance across both links automatically when they are of equal
variance (equal
cost),
but EIGRP can also load-balance across unequal-cost links as well if we use the
variance
command.
The variance metric is set to 1 by default you can change the metric anywhere
up to 128.
if
the variance is set to 1, only routes with the same metric as the successor
will be installed in the local routing table. And, if the variance is set to 2,
any EIGRP learned route with a metric less than two times the successor metric
will be installed in the local routing table (if it is already a feasible
successor).
Debug eigrp packet
command :that will show our Hello packets
being sent between neighbor routers:
Corp#debug
eigrp packet
EIGRP Packets debugging is on
(UPDATE, REQUEST, QUERY, REPLY, HELLO, IPXSAP, PROBE, ACK,
STUB,
SIAQUERY, SIAREPLY)
Corp#
*Mar 21 23:17:35.050: EIGRP: Sending HELLO on
FastEthernet0/1
*Mar 21 23:17:35.050: AS 10, Flags 0x0, Seq 0/0 idbQ 0/0
iidbQ un/rely 0/0
debug ip eigrp notification command :this
command’s output shouldn’t show you anything at all! That’s right—the only time
you’ll see output from this command is if there’s a problem on your network or
you’ve added or deleted a network from a router
No comments:
Post a Comment